This blog is designed to provide information about Routing, switching, Firewall technologies for CCIE aspirants.I started my study a few Years ago with hopes to achieve the covered CCIE certification. It seems the more I study more I find that I need to study. But the journey has started ...
Search This Blog
Tuesday, August 9, 2011
Wednesday, July 27, 2011
Bgp route Aggregation
R1 configuration
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.1.1.0 mask 255.255.255.0
neighbor 131.1.12.2 remote-as 200
no auto-summary
R1#sh ip bgp
BGP table version is 43, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.0/24 0.0.0.0 0 32768 i
*> 2.2.0.0/22 131.1.12.2 0 0 200 i -------route aggregation is done for 2.2.x.x network
R5 configuration
interface Loopback2
ip address 2.2.0.2 255.255.255.0
!
interface Loopback3
ip address 2.2.1.2 255.255.255.0
!
interface Loopback4
ip address 2.2.2.2 255.255.255.0
!
interface Loopback5
ip address 2.2.3.2 255.255.255.0
router bgp 200
no synchronization
bgp log-neighbor-changes
network 2.2.0.0 mask 255.255.255.0
network 2.2.1.0 mask 255.255.255.0
network 2.2.2.0 mask 255.255.255.0
network 2.2.3.0 mask 255.255.255.0
aggregate-address 2.2.0.0 255.255.252.0 as-set summary-only
neighbor 131.1.12.1 remote-as 100
no auto-summary
BGP Dampening using Route-Map
Task 1
Configure R1 and R2 should apply the route dampening for prefixes 40.x.x.x according to the following:
- Max-Suppres=50 minutes
- Suppress=2000 points
- Reuse=800 points
- Half-Time=10 minutes
- Max-Suppres=90 minutes
- Suppress=2500 points
- Reuse=700 points
- Half-Time=20 minutes
R1 configuration
router bgp 123
no synchronization
bgp router-id 172.16.101.1
bgp log-neighbor-changes
bgp dampening route-map DAMPEN
network 172.16.101.0 mask 255.255.255.0
neighbor 10.1.13.3 remote-as 123
neighbor 10.1.14.4 remote-as 40
neighbor 10.1.14.4 next-hop-self
no auto-summary
ip prefix-list NET_40 seq 5 permit 40.0.0.0/8 le 32
!
ip prefix-list NET_44 seq 5 permit 44.0.0.0/8 le 32
!
!
!
route-map DAMPEN permit 10
match ip address prefix-list NET_40
set dampening 15 800 3000 50
!
route-map DAMPEN permit 20
match ip address prefix-list NET_44
set dampening 15 800 3000 50
R1#sh ip bg dampening parameters
dampening 15 800 3000 50 (route-map DAMPEN 10)
Half-life time : 15 mins Decay Time : 1280 secs
Max suppress penalty: 8051 Max suppress time: 50 mins
Suppress penalty : 3000 Reuse penalty : 800
dampening 15 800 3000 50 (route-map DAMPEN 20)
Half-life time : 15 mins Decay Time : 1280 secs
Max suppress penalty: 8051 Max suppress time: 50 mins
Suppress penalty : 3000 Reuse penalty : 800
R1#
R2 configuration
router bgp 123
no synchronization
bgp log-neighbor-changes
bgp dampening route-map DAMPEN
network 172.16.102.0 mask 255.255.255.0
neighbor 10.1.23.3 remote-as 123
neighbor 10.1.23.3 next-hop-self
neighbor 10.1.24.4 remote-as 40
no auto-summary
ip prefix-list NET_40 seq 5 permit 40.0.0.0/8 le 32
!
ip prefix-list NET_44 seq 5 permit 44.0.0.0/8 le 32
!
!
!
route-map DAMPEN permit 10
match ip address prefix-list NET_40
set dampening 15 800 3000 50
!
route-map DAMPEN permit 20
match ip address prefix-list NET_44
set dampening 20 700 2500 90
r2# sh ip bgp dampening parameters
dampening 15 800 3000 50 (route-map DAMPEN 10)
Half-life time : 15 mins Decay Time : 1280 secs
Max suppress penalty: 8051 Max suppress time: 50 mins
Suppress penalty : 3000 Reuse penalty : 800
dampening 20 700 2500 90 (route-map DAMPEN 20)
Half-life time : 20 mins Decay Time : 3190 secs
Max suppress penalty: 15816 Max suppress time: 90 mins
Suppress penalty : 2500 Reuse penalty : 700
Thursday, July 21, 2011
Bgp route reflector
R1 configuration and output
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.0.0.0
neighbor 10.1.1.2 remote-as 100
neighbor 10.1.1.2 route-reflector-client
neighbor 10.1.1.3 remote-as 100
neighbor 10.1.1.3 route-reflector-client
no auto-summary
no synchronization
bgp log-neighbor-changes
network 1.0.0.0
neighbor 10.1.1.2 remote-as 100
neighbor 10.1.1.2 route-reflector-client
neighbor 10.1.1.3 remote-as 100
neighbor 10.1.1.3 route-reflector-client
no auto-summary
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 1.0.0.0/8 is directly connected, Loopback0
B 2.0.0.0/8 [200/0] via 10.1.1.3, 00:05:39
B 3.0.0.0/8 [200/0] via 10.1.1.2, 00:05:38
C 10.0.0.0/8 is directly connected, FastEthernet0/0
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 1.0.0.0/8 is directly connected, Loopback0
B 2.0.0.0/8 [200/0] via 10.1.1.3, 00:05:39
B 3.0.0.0/8 [200/0] via 10.1.1.2, 00:05:38
C 10.0.0.0/8 is directly connected, FastEthernet0/0
R1#sh ip bgp
BGP table version is 14, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 0.0.0.0 0 32768 i
*>i2.0.0.0 10.1.1.3 0 100 0 i
*>i3.0.0.0 10.1.1.2 0 100 0 i
BGP table version is 14, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 0.0.0.0 0 32768 i
*>i2.0.0.0 10.1.1.3 0 100 0 i
*>i3.0.0.0 10.1.1.2 0 100 0 i
R2 configuration and output
router bgp 100
no synchronization
bgp log-neighbor-changes
network 2.0.0.0
neighbor 10.1.1.1 remote-as 100
no auto-summary
no synchronization
bgp log-neighbor-changes
network 2.0.0.0
neighbor 10.1.1.1 remote-as 100
no auto-summary
R2# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
B 1.0.0.0/8 [200/0] via 10.1.1.1, 00:04:47
C 2.0.0.0/8 is directly connected, Loopback0
B 3.0.0.0/8 [200/0] via 10.1.1.2, 00:04:46
C 10.0.0.0/8 is directly connected, FastEthernet0/0
R2#sh ip bgp
BGP table version is 12, local router ID is 10.1.1.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i1.0.0.0 10.1.1.1 0 100 0 i
*> 2.0.0.0 0.0.0.0 0 32768 i
*>i3.0.0.0 10.1.1.2 0 100 0 i
R2#
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
B 1.0.0.0/8 [200/0] via 10.1.1.1, 00:04:47
C 2.0.0.0/8 is directly connected, Loopback0
B 3.0.0.0/8 [200/0] via 10.1.1.2, 00:04:46
C 10.0.0.0/8 is directly connected, FastEthernet0/0
R2#sh ip bgp
BGP table version is 12, local router ID is 10.1.1.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i1.0.0.0 10.1.1.1 0 100 0 i
*> 2.0.0.0 0.0.0.0 0 32768 i
*>i3.0.0.0 10.1.1.2 0 100 0 i
R2#
R3 configuration and output
router bgp 100
no synchronization
bgp log-neighbor-changes
network 3.0.0.0
neighbor 10.1.1.1 remote-as 100
no auto-summary
no synchronization
bgp log-neighbor-changes
network 3.0.0.0
neighbor 10.1.1.1 remote-as 100
no auto-summary
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
B 1.0.0.0/8 [200/0] via 10.1.1.1, 00:05:24
B 2.0.0.0/8 [200/0] via 10.1.1.3, 00:05:24
C 3.0.0.0/8 is directly connected, Loopback0
C 10.0.0.0/8 is directly connected, FastEthernet0/0
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
B 1.0.0.0/8 [200/0] via 10.1.1.1, 00:05:24
B 2.0.0.0/8 [200/0] via 10.1.1.3, 00:05:24
C 3.0.0.0/8 is directly connected, Loopback0
C 10.0.0.0/8 is directly connected, FastEthernet0/0
R3#sh ip bgp
BGP table version is 14, local router ID is 10.1.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i1.0.0.0 10.1.1.1 0 100 0 i
*>i2.0.0.0 10.1.1.3 0 100 0 i
*> 3.0.0.0 0.0.0.0 0 32768 i
BGP table version is 14, local router ID is 10.1.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i1.0.0.0 10.1.1.1 0 100 0 i
*>i2.0.0.0 10.1.1.3 0 100 0 i
*> 3.0.0.0 0.0.0.0 0 32768 i
R3#sh ip bgp summary
BGP router identifier 10.1.1.2, local AS number 100
BGP table version is 14, main routing table version 14
3 network entries using 360 bytes of memory
3 path entries using 156 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 2) using 32 bytes of memory
BGP using 944 total bytes of memory
BGP activity 3/0 prefixes, 8/5 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.1.1.1 4 100 33 27 14 0 0 00:05:31 2
R3#
BGP router identifier 10.1.1.2, local AS number 100
BGP table version is 14, main routing table version 14
3 network entries using 360 bytes of memory
3 path entries using 156 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 2) using 32 bytes of memory
BGP using 944 total bytes of memory
BGP activity 3/0 prefixes, 8/5 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.1.1.1 4 100 33 27 14 0 0 00:05:31 2
R3#
Tuesday, June 14, 2011
Area authentication in ospf
Area authentication
To enable authentication for an OSPF area, use the area authentication command in router configuration mode. To remove an authentication specification of an area or a specified area from the configuration, use the no form of this command.
area area-id authentication [message-digest]
no area area-id authentication [message-digest]
area 0 authentication
!−−− Plain text authentication is enabled for
!−−− all interfaces in Area 0.
!---- Should be enable on all the Routers
Eg:-
Router ospf 10
log−adjacency−changes
network 70.0.0.0 0.255.255.255 area 0
network 192.16.64.0 0.0.0.255 area 0
area 0 authentication Under Ospf process
To enable authentication for an OSPF area, use the area authentication command in router configuration mode. To remove an authentication specification of an area or a specified area from the configuration, use the no form of this command.
area area-id authentication [message-digest]
no area area-id authentication [message-digest]
area 0 authentication
!−−− Plain text authentication is enabled for
!−−− all interfaces in Area 0.
!---- Should be enable on all the Routers
Eg:-
Router ospf 10
log−adjacency−changes
network 70.0.0.0 0.255.255.255 area 0
network 192.16.64.0 0.0.0.255 area 0
area 0 authentication Under Ospf process
Monday, May 16, 2011
A few learning notes on BGP command
neighbor 1.1.1.1 ttl-security hops 2
neighbor 1.1.1.1 disable-connected-check
By default BGP will check that a eBGP peer is directly connected by comparing the peer address against directly connected interface addresses. The BGP router will not even try to connect (no packets hit the wire) if the neighbor doesn't first pass the connected test. Similarly the remote peer will not accept the peer connection if it does not pass the connected test. This is beyond the IP TTL limitations related to eBGP, eBGP multihop and TTL security - the checking is at the application layer of BGP.
This check is disabled by :
* neighbor disable-connected-check , or
* neighbor ebgp-multihop <ttl> , when TTL > 1
The disable-connect-check command is used when you want to establish peering of directly connect routers using the loopback interface (using the loopback as the BGP source is configured with neighbor update-source).
Eg:-
network 1.1.1.0 mask 255.255.255.0
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 ttl-security hops 2
neighbor 2.2.2.2 update-source Loopback0
Sunday, May 15, 2011
Monday, May 9, 2011
Friday, May 6, 2011
Frame-relay Monitoring and Troubleshooting
Frame Relay is a high-performance WAN protocol that operates at the physical and data link layers of the OSI reference model. Frame Relay originally was designed for use across Integrated Services Digital Network (ISDN) interfaces. Today, it is used over a variety of other network interfaces as well. This article focuses on Frame Relay's specifications and applications in the context of WAN services.
http://docwiki.cisco.com/wiki/Frame_Relay
Monitoring -- Frame Relay Troubleshooting Tasks
To troubleshoot and resolve Voice over Frame Relay configuration issues, perform the following tasks:
- If no calls are going through, ensure that the frame-relay voice bandwidth command is configured.
- If VoFR is configured on a PVC and there are problems with data connectivity on that PVC, ensure that the frame-relay fragment command has been configured.
- If data is not being transmitted but fragmentation is configured, ensure that Frame Relay traffic shaping is turned on.
- If the problem is with the dial plan or the dial peers, use the show dial-plan number command with the argument dial string to display which dial peers are being used when a specific number is called.
- If there are problems connecting an FRF.11 trunk call, ensure that the session protocol command in dial peer configuration is set to frf11-trunk.
- If FRF.11 trunk calls on the Cisco 2600 or Cisco 3600 series routers are being configured, verify that the called-number vofr command in dial peer configuration is configured and that its number matches the destination pattern of the corresponding POTS dial peer.
- Ensure that the voice port is set to no shutdown.
- Ensure that the serial port or the T1/E1 controller is set to no shutdown.
- Toggle the voice port by first entering shutdown and then no shutdown every time the connection trunk or no connection trunk command is entered.
- Enter the show frame-relay pvc command to show the status of the PVCs.
- Enter the show frame-relay vofr command with the arguments interface, dlci, cid to show statistics and information on the open subchannels.
- Enter the show frame-relay fragment command with the arguments interface number and dlci to show the Frame Relay fragmentation configuration.
- Enter the show traffic-shape queue command to display the traffic-shaping information if Frame Relay traffic shaping is configured. The queue option displays the queueing statistics. For more information about traffic shaping,
STP.RSTP and PSTP
STP(Spanning-tree Protocol): Layer 2 protocol used in LAN enviroment to
avoid:
Mac-Table Inestability
Multiples copies of frames.
RSTP(Rapid Spanning Tree Protocol-802.1w Standard): it is the enhanced protocol of STP,
the main caracteristic of this one is Faster than STP (it converge in less than 6 seconds). PVST+ (Per Vlan Spanning Tree Plus) : This feature (by cisco) is used to create an instace of
STP for each VLAN. e.g.
modify the parameters (like to make root bridge for a specific VLAN) independiently
accord to your design goals.
MIST(Multiple Instances of Spaning Tree-802.1s): This protocol is the equivalent for PVST, however
this protocol just can be used in conjunction with RSTP.
Some useful Link :-
http://en.wikipedia.org/wiki/Rapid_Spanning_Tree_Protocol#Rapid_Spanning_Tree_Protocol_.28RSTP.29
Frame-relay with point to point interfaces
Frame-relay configuration
Frame-relay with point to point interfaces (ospf)
-------------------------------------------------------------Frame-relay router Output
Frame-relay-switch#sh frame-relay pvc | in 202
DLCI = 202, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE = Serial1/0
Frame-relay-switch#sh frame-relay pvc | in 501
DLCI = 501, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE = Serial1/1
Frame-relay-switch#
R3 configuration and output
interface Serial1/0
ip address 192.168.1.9 255.255.255.252
encapsulation frame-relay
ip ospf network point-to-point
no fair-queue
serial restart-delay 0
frame-relay map ip 192.168.1.10 202 broadcast
no frame-relay inverse-arp
.
R3#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
4.4.4.4 0 FULL/ - 00:00:36 192.168.1.10 Serial1/0
R3#sh frame-relay map
Serial1/0 (up): ip 192.168.1.10 dlci 202(0xCA,0x30A0), static,
broadcast,
CISCO, status defined, active
R3#
R3#sh frame-relay pvc
PVC Statistics for interface Serial1/0 (Frame Relay DTE)
Active Inactive Deleted Static
Local 1 0 0 0
Switched 0 0 0 0
Unused 0 2 0 0
DLCI = 201, DLCI USAGE = UNUSED, PVC STATUS = INACTIVE, INTERFACE = Serial1/0
input pkts 0 output pkts 0 in bytes 0
out bytes 0 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:11:46, last time pvc status changed 00:11:46
DLCI = 202, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0
input pkts 77 output pkts 63 in bytes 6604
out bytes 5468 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 53 out bcast bytes 4428
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:11:46, last time pvc status changed 00:11:36
DLCI = 203, DLCI USAGE = UNUSED, PVC STATUS = INACTIVE, INTERFACE = Serial1/0
input pkts 0 output pkts 0 in bytes 0
out bytes 0 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:11:46, last time pvc status changed 00:11:46
R3#
R4 configuration and output
interface Serial1/1
ip address 192.168.1.10 255.255.255.252
encapsulation frame-relay
ip ospf network point-to-point
serial restart-delay 0
frame-relay map ip 192.168.1.9 501 broadcast
no frame-relay inverse-arp
!
R4#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 0 FULL/ - 00:00:32 192.168.1.9 Serial1/1
R4#
R4#sh frame-relay map
Serial1/1 (up): ip 192.168.1.9 dlci 501(0x1F5,0x7C50), static,
broadcast,
CISCO, status defined, active
R4#sh frame-relay pvc interface serial 1/1
PVC Statistics for interface Serial1/1 (Frame Relay DTE)
Active Inactive Deleted Static
Local 1 0 0 0
Switched 0 0 0 0
Unused 0 2 0 0
DLCI = 501, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/1
input pkts 59 output pkts 72 in bytes 5132
out bytes 6184 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 62 out bcast bytes 5144
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:12:59, last time pvc status changed 00:10:49
DLCI = 502, DLCI USAGE = UNUSED, PVC STATUS = INACTIVE, INTERFACE = Serial1/1
input pkts 0 output pkts 0 in bytes 0
out bytes 0 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:13:03, last time pvc status changed 00:13:03
DLCI = 503, DLCI USAGE = UNUSED, PVC STATUS = INACTIVE, INTERFACE = Serial1/1
input pkts 0 output pkts 0 in bytes 0
out bytes 0 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:13:04, last time pvc status changed 00:13:04
R4#
Frame-relay configuration with non-broadcast network
R3 configuration and output
R3#sh run int serial 1/0
Building configuration...
Current configuration : 264 bytes
!
interface Serial1/0
ip address 192.168.1.9 255.255.255.0
encapsulation frame-relay
ip ospf network non-broadcast
no fair-queue
serial restart-delay 0
frame-relay map ip 192.168.1.11 203
frame-relay map ip 192.168.1.10 202
no frame-relay inverse-arp
end
interface Loopback0
ip address 3.3.3.3 255.255.255.255
end
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
neighbor 192.168.1.10
neighbor 192.168.1.11
!
R3#
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/65] via 192.168.1.10, 00:20:35, Serial1/0
7.0.0.0/32 is subnetted, 1 subnets
O 7.7.7.7 [110/65] via 192.168.1.11, 00:20:35, Serial1/0
C 192.168.1.0/24 is directly connected, Serial1/0
R3#
R3#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
4.4.4.4 0 FULL/DROTHER 00:01:58 192.168.1.10 Serial1/0
7.7.7.7 0 FULL/DROTHER 00:01:32 192.168.1.11 Serial1/0
R3#
R4 configuration and output
R4#sh running-config interface serial 1/1
Building configuration...
Current configuration : 269 bytes
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
interface Serial1/1
ip address 192.168.1.10 255.255.255.0
encapsulation frame-relay
ip ospf network non-broadcast
ip ospf priority 0
serial restart-delay 0
frame-relay map ip 192.168.1.11 501
frame-relay map ip 192.168.1.9 501
no frame-relay inverse-arp
end
R4#
R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 192.168.1.9, 00:22:16, Serial1/1
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback0
7.0.0.0/32 is subnetted, 1 subnets
O 7.7.7.7 [110/65] via 192.168.1.11, 00:22:06, Serial1/1
C 192.168.1.0/24 is directly connected, Serial1/1
R4#
R4#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 1 FULL/DR 00:01:35 192.168.1.9 Serial1/1
R4#
R7 configuration and output
interface Serial1/2
ip address 192.168.1.11 255.255.255.0
encapsulation frame-relay
ip ospf network non-broadcast
ip ospf priority 0
serial restart-delay 0
frame-relay map ip 192.168.1.10 301
frame-relay map ip 192.168.1.9 301
no frame-relay inverse-arp
end
R7#sh running-config interface loopback 0
Building configuration...
Current configuration : 63 bytes
!
interface Loopback0
ip address 7.7.7.7 255.255.255.255
end
R7#
R7#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 192.168.1.9, 00:24:08, Serial1/2
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/65] via 192.168.1.10, 00:23:58, Serial1/2
7.0.0.0/32 is subnetted, 1 subnets
C 7.7.7.7 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Serial1/2
R7#
R7#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 1 FULL/DR 00:01:37 192.168.1.9 Serial1/2
R7#
Subscribe to:
Posts (Atom)